أرشيف | جونيبر RSS for this section

كيفية عمل لاب جونيبر على برنامج GNS3

111

222

333444

Advertisements

فوائد إستخدام الأوامر المساعدة في نظام JunOS

 يعلم الجميع أن نظام تشغيل الشبكي “جونوس” المستخدم في أنظمة عتاد شركة Juniper مبني في الأساس على نواة نظام FreeBSD المتفرع من نظام Unix وكمهندس أو مدير للشبكات لابد أن تدرك أن أهم ما يميز هذا النظام هى (المرونة), فالأوامر داخل النظام مقسمة تقسيم هرمي وذلك يسهل علينا الكثير فإن لم يكن لديك الخبرة الكافية في التعامل مع هذا النوع من العتاد وكيفية عمل إعداداته سواء كان راوترات أو سويتشات أو فايروول أو غيرها فهذا يوم سعدك لأنك لن تجد أى معاناة في الحصول على المعلومات المطلوبة والتى ستفيدك في إكمال عملك بدون اللجوء إلى أى موقع أو محرك بحث.

junos-help 1

اليوم سنتحدث عن الأوامر المساعدة الموجودة في “جونوس” وكما هو واضح في الصورة السابقة أن هناك خمس أوامر ورموز يمثلوا الهيكل الأساسى لأى معلومة من الممكن أن تحصل عليها لأن طرق الحصول على المعلومة مختلفة .

فعلى سبيل المثال ” من الممكن أن نحتاج لكتابة أمر واحد للحصول على ما نريده من مساعدة , ومن الممكن أن نحتاج لكتابة أمرين أو ثلاثة كما سنرى لاحقاً بإذن الله.

1- أمر Apropos
يستخدم هذا الأمر لإيجاد أمر ما عن طريق كلمة واحدة , فمثلا اذا كنت تريد كتابة أمر على الراوتر ولكنك لا تتذكر غير نصفه أو جزء بسيط منه سواء في بداية الأمر أو نهايته أو منتصفه كأمر كان به كلمة flow وتريد أن تبحث عنه؟ سنكتب الأمر التالي وسنجد أمامنا كل الأوامر التى تحتوى على كلمه flowjunos-help 2

2- أمر Reference
هذا الامر مفيد لمن يريد أن يحصل على معلومات عن كتابة أمر معين

junos-help 3

3- أمر Syslog
هذا الأمر مهم جداً في عملية حل المشاكل والأخطاء أو ما يعرف بالـ troubleshooting, فإذا ظهرت لك رسالة خطأ أو حاولت قراءة السجلات “logs” فهذا الأمر هو ما سيشرح لك تفاصيل الرسالة error التى ظهرت لك .

junos-help 4

وللتوضيح أكثر سنذكر مثال على هذا الأمر ولنفترض أن هناك خطاً ما حدث وظهرت لك هذه الرسالة وأنت تريد أن تعرف ما هى حتى تستطيع حل المشكلة؟ فكل ما عليك هو أن تقوم بكتابة الأمر التالى كما هو واضح بالصورة وستظهر لك كل المعلومات عن هذه الرسالة وسبب المشكلة .

junos-help 5

4- أمر Tip
هذا الأمر مثل الرجل الحكيم فهو يقدم نصائح مختلفة عن الأوامر الموجودة بداخل نظام “جونوس“

junos-help 6

5- أمر Topic
هذا الأمر يشرح لك ما تبحث عنه بشكل مفصل ويطلعك أيضاً على أوامر الاعدادات كاملة .

junos-help 7

6- رمز |
هذا الرمز هو المفضل والمحبب لقلب كل مهندس كسول فهو يساعد على تفحيص وتنقيح الأوامر الفرعية التى تحتاجها مع الأمر الأساسي وبذلك يختصر الكثير من الوقت في عمل الإعدادات المطلوبة وإن لم تفهم ماذا أقصد فالصورة التالية هى خير دليل لتوضيح فائدته .

junos-help 8

 

*هناك بالطبع أوامر مخفية داخل نظام “جونوس“ من ضمنها أوامر مساعدة سنتحدث عنها لاحقاً بإذن الله

ولمزيد من المعلومات يمكنكم الدخول على الرابط التالى من مكتبة NetworkSet  وتحميل كتاب DAY ONE- JUNOS TIPS, TECHNIQUES, AND TEMPLATES 2011 أو تحميل كتاب JUNOS OS For Dummies.

المصدر

إعدادات أساسية لتشغيل راوتر جونير يعمل بنظام [JunOS]

هذه التدوينة ستكون للمبتدئين في أستخدام JunOS “نظام تشغيل أجهزة جونيبر” سنتعرف فيها على بعض الأوامر الأساسية وكيفية التعامل مع النظام وسنختار كمثال راوتر  لنعرف كيفية عمل Configuration له؟

والآن سنبدأ بـ الإعدادات الأساسية كتغير أسم الراوتر وإضافة أسم الدومين وإعطاء IP للمنافذ وإضافة أسم للسيرفر وتغير كلمة مرور الـ root وتعديل الوقت والتاريخ وغيرها, والان وبعد كتابة أسم الرووت وكلمة المرور سنقوم بعمل التالي :

root@ cli
root>
root> configure
[edit]
root@# set system host-name R1
root@# set system domain-name NetworkSet.net
root@# set system name-server 10.2.2.1
root@# set system backup-router 10.2.2.1
root@# set interfaces fxp0 unit 0 family inet address 10.2.2.2/24
root@# set system ntp server  192.168.2.100
root@# set system time-zone Africa/cairo
root@# set system services ssh
root@# set interfaces lo0 unit 0 family inet address  10.200.200.1/32
root@# set system root-authentication plain-text-password
New password: *********
Retype password: *********
root@# commit
root@R1# exit

إنشاء مستخدم
root@R1# set system login user Oozy089 class superuser
root@R1# set system log user Oozy089 authentication plain-text-password

إضافة default route
root@R1# set routing-options static route 0.0.0.0/0 next-hop 10.0.0.10

تفعيل خدمة SHH
root@R1# set system services ssh
root@R1# set system services ssh connection-limit 100 (تحديد خطوط الاتصال لتجنب هجمات DOS)
root@R1# set system services ssh rate-limit 3
root@R1# set interaces lo0 unit family inet address 172.16.22.111
root@R1# set system login user Ahmed class superuser
root@R1# set system log user Ahmed authentication plain-text-password
root@R1# commit
commit complete

تفعيل فلتر  AS-path access-list
protocols {
bgp {
group “ebgp-test” {
type external;
import test-in;
peer-as 200;
neighbor 192.168.1.1 {
}
}
policy-options {
policy-statement test {
from as-path [test test1];
then reject;
}
set policy-options as-path a “.*1234″
set policy-options as-path b “.*5678″
}

لتشغيل بروتوكول SNMP
set snmp location “NetworkSet.net”
set snmp contact “SNMP@NetworkSet.net”
set snmp community nMSuser authorization read-only
set snmp community nMSuser clients 172.16.2.1/32
set snmp community nMSuser clients 172.16.9.0/24

إضافة حسابات جديدة
root@R1# set system login user admin full-name Administrator
root@R1# set system login user admin uid 100
root@R1# set system login user admin class super-user
root@R1# set system login user admin authentication plain-text-password ******

ولمشاهدة ملفات logs
root@R1# run show log
root@R1# run show log messages

ولجمع معلومات أكثر عن النظام يمكنكم أستخدام أحد هذه الأوامر
root@R1# show version
root@R1# show version detail
root@R1# show system processes
root@R1# run show system processes | match /syslogd
root@R1# run request support information
root@R1# run file list detail /var/tmp
root@R1# run show system users
root@R1# run show system uptime

لأخذ نسخة إحتياطية من الإعدادات
root@R1# file copy /config/juniper.conf.gz box:/root/tmp
root@R1# save box:configING
root@R1# save configING ثم أكتب المكان الذى ستضع به ملف الإعدادات الإحتياطية

لرؤية ملف الإعدادات الإحتياطي
root@R1# run file show configING

لمعرفة المساحة الفارغة
root@R1# run show system storage

تسطيب jinstall مختلف عن الموجود على الراوتر
root@R1# request system software add validate box:jinstall-8.5R3.4-domestic-signed.tgz
root@R1# file copy box:jinstall-8.5R3.4-domestic-signed.tgz /var/tmp
root@R1# request system software add validate /var/tmp/jinstall-8.5R3.4-domestic-signed.tgz
root@R1# request system reboot

إجبار حساب على الخروج من الراوتر
Root@R1> request system logout user Oozy089

.

.

ولمزيد من المعلومات حول أوامر نظام “جونوس” يمكنكم تحميل كتاب Junos® OS CLI User Guide Release 10.3

أو تحميل كتاب Junos® OS CLI User Guide Release 12.1 

أو تحميل كتاب JUNOS Command Line Interface